Post #1
0 votes
Sandra
Reputation198
Posts: 17
Joined: 10/15/2024, 08:30 AM
Posted: 06/08/2026, 08:11 AM
New CICS DB2 program on a fresh region. SQL works from batch binds but the transaction always fails with -922 and SQLERRMC mentions user authorization. EDF shows P.auth as CICSUSER no matter which RACF id I sign on with.
Plan has EXECUTE granted to PUBLIC in the DB2 catalog. Region does not use RACF signon yet. What did we miss in DB2CONN setup?